yoshiweb.NET-blog



HOME > blog > ドキュメント化されていないクラスの対応バージョンは?
« トゥイーンの関数を作成するツール | mx.transitions.OnEnterFrameBeacon の使い方 »

ドキュメント化されていないクラスの対応バージョンは?

mx.transitions.BroadcasterMX は Flash Player 6.0.79.0 未満のバージョンで再生しても大丈夫かな?ちょっと試した&ソースを見る限り大丈夫そうだけど、ある環境では動作しないとか落とし穴があったら嫌だなと思って...。やっぱり v2コンポーネント と同様に Flash Player 6.0.79.0 以降対応って考えたほうがいいのでしょうか?

OnEnterFrameBeaconクラス を使いたいけどこの中で BroadcasterMXクラス が使われてるからどうしたものかと...。OnEnterFrameBeaconクラス の BroadcasterMXクラス部分を AsBroadcasterクラス で代用すれば問題なく使えるかな?

EventDispatcherクラス 同様に、BroadcasterMX や OnEnterFrameBeacon たちなど便利なクラスも LiveDocs に載せて欲しいな...と。

自分が探せてなかっただけだったらゴメソ。

Flash非公式テクニカルノート - BroadcasterMXクラス (API)
F-site - OnEnterFrameBeaconクラスを使う
Flash 8 Live Docs - EventDispatcher
Flash 8 Live Docs - AsBroadcaster
投稿者 yoshiweb - ActionScript - 2005/10/24 - 11:15:57 - Permalink
このエントリーをはてなブックマークに追加
タグ:

Comments

コメントしてください

コメントを書く

※ スパム対策のためコメント内の URL は全角で書いてください。あとで半角に変換します。