yoshiweb.NET

変数名やメソッド名のつけかた 【Flash】

決まりじゃないけど変数名やメソッド名のつけかたにはどんな慣習があるんでしょう?
変数名の最初に型接頭辞を付加するハンガリアン(ハンガリー)記法というのが昔あったみたいだけど、最近はあまり使われていないとか書いてあるサイトもあるし。

以下、Java系のサイトを参考にネットで拾った情報をつらつら書いていきます。
●クラス名 - 大文字で始めて、単語の区切りを大文字にする。
●メソッド名 - 小文字で始まる動詞ではじめる。複数の単語で構成される場合、単語の区切りを大文字にする。
●変数名 - 小文字で始めて、単語の区切りを大文字にする。
●定数名 - 大文字だけで書いて、単語の区切りを「 _ (アンダーバー)」にする。
以上、共通して書かれていそうなことです。
以下はちょっと不透明

●クラスメンバ変数 - 「 _ (アンダーバー)」で始めて、型をあらわす接頭語は付けない。
↑「_alpha」とかプロパティがアンダーバーから始まってるのがこれなのかな?

Flash版ハンガリアン記法みたいなものを定義しているサイトとかありませんか?


Macromedia - Flash での命名術
Flashヘルプ - 一般的な命名ガイドライン
Macromedia - FCSアプリケーション作成における最善の方法
Flash-JP - 変数などの名前について
fladdict.net - AS2のコーディング・スタンダート
Flex Coder - [Flex]コーディングガイドライン


【追記】
ActionScript 3.0 コーディング規約...みたいなもの
Coding Conventions - Flex SDK - Adobe Open Source

と、その日本語訳
trick7 - ActionScript 3.0 コーディング規約の日本語訳


投稿日 : 2005年01月26日 - yoshiweb - カテゴリ: ActionScript

コメント

投稿者 : どか

おじゃまします~

以前自分はすごい適当な名前をつけてたんですが
(ドラクエ1の勇者は「ああああ」でした)
最近こりゃいかんってことでしっかりつけようキャンペーン始めました。
OOPだと、メソッド名しっかりしないと過去の自分を恨むことになりかねないですからね。
で、いつも思うのが、○○の数を返すメソッド。
getNantokaNum()
とか
getNantokaMaxNum()(こりゃ変かな)
とか
getSize()
とか
Nantokaクラスのサイズ限定なら
size()
とかがいいんだろうけど、
こんなことで悩むのがなんかすごい面倒で
いやな作業ですね。

後からいっぺんにメソッド名や変数名変えられるIDEじゃないと
きついです。
2005年02月07日 02時41分34秒

投稿者 : yoshiweb

>どかさん
こんにちは、コメントありがとうございます!
悩んでいるのはみんな一緒なんですね。

変数名も単に英語にすると長くて読みにくかったり、
でも短くすると後で何の変数か覚えてなくて困ったりして...。

一応できるだけコメントは書くようにしてるけど
コメントを書かないまま作業をすすめちゃうことがよくあるから
毎度毎度、後でイタイ思いを繰り返してます。>自分
2005年02月07日 21時13分15秒

投稿者 : Alma

It's a shame you don't have a donate button! I'd
without a doubt donate to this superb blog! I guess for now i'll
settle for book-marking and adding your RSS feed to my Google account.

I look forward to new updates and will talk about this website with my Facebook
group. Chat soon!
2021年03月18日 10時14分47秒